blob: 3aab65bf5ba3bdc2f80853c1710b24b39dffdeb7 [file] [log] [blame]
SUMMARY = "UNIX Shell similar to the Korn shell"
DESCRIPTION = "Zsh is a shell designed for interactive use, although it is also a \
powerful scripting language. Many of the useful features of bash, \
ksh, and tcsh were incorporated into zsh; many original features were added."
HOMEPAGE = "http://www.zsh.org"
SECTION = "base/shell"
LICENSE = "zsh"
LIC_FILES_CHKSUM = "file://LICENCE;md5=1a4c4cda3e8096d2fd483ff2f4514fec"
DEPENDS = "ncurses bison-native libcap libpcre gdbm groff-native"
SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz"
SRC_URI[md5sum] = "dfe156fd69b0d8d1745ecf6d6e02e047"
SRC_URI[sha256sum] = "957bcdb2c57f64c02f673693ea5a7518ef24b6557aeb3a4ce222cefa6d74acc9"
inherit autotools gettext update-alternatives
EXTRA_OECONF = " \
--bindir=${base_bindir} \
--enable-etcdir=${sysconfdir} \
--enable-fndir=${datadir}/${PN}/${PV}/functions \
--enable-site-fndir=${datadir}/${PN}/site-functions \
--with-term-lib='ncursesw ncurses' \
--with-tcsetpgrp \
--enable-cap \
--enable-multibyte \
--disable-gdbm \
--disable-dynamic \
zsh_cv_shared_environ=yes \
"
# Configure respects --bindir from EXTRA_OECONF, but then Src/Makefile will read bindir from environment
export bindir="${base_bindir}"
EXTRA_OEMAKE = "-e MAKEFLAGS="
ALTERNATIVE_${PN} = "sh"
ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
ALTERNATIVE_TARGET[sh] = "${base_bindir}/${BPN}"
ALTERNATIVE_PRIORITY = "100"
export AUTOHEADER = "true"
do_configure () {
gnu-configize --force ${S}
oe_runconf
}
do_install_append () {
rm -fr ${D}/usr/share
rmdir --ignore-fail-on-non-empty ${D}/usr
}
pkg_postinst_${PN} () {
touch $D${sysconfdir}/shells
grep -q "bin/zsh" $D${sysconfdir}/shells || echo /bin/zsh >> $D${sysconfdir}/shells
grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
}
FILES_${PN}-dbg += "\
${libdir}/${PN}/${PV}/${PN}/.debug/*.so \
${libdir}/${PN}/${PV}/${PN}/db/.debug/*.so \
${libdir}/${PN}/${PV}/${PN}/net/.debug/*.so \
"