blob: 0183c2e41ae86a900ba7f0c83f8a5fa06bd18968 [file] [log] [blame]
DESCRIPTION = "A modern, C++-native, header-only, test framework for unit-tests, \
TDD and BDD - using C++11, C++14, C++17 and later."
AUTHOR = "Phil Nash, Martin Horenovsky and others"
HOMEPAGE = "https://github.com/catchorg/Catch2"
LICENSE = "BSL-1.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
SRC_URI = "git://github.com/catchorg/Catch2.git \
file://0001-Fix-convert-from-char-on-ARM-build.patch"
SRCREV = "9e1bdca4667295fcb16265eae00efa8423f07007"
S = "${WORKDIR}/git"
inherit cmake python3native
# Header-only library
RDEPENDS_${PN}-dev = ""
RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
do_install_append() {
rm ${D}/${datadir}/Catch2/lldbinit
rm ${D}/${datadir}/Catch2/gdbinit
rmdir ${D}/${datadir}/Catch2/
}