state: remove ${PN} pkg

By default OE adds ${PN} as a runtime dependency to ${PN}-[static]dev

Remove ${PN} since it will never have any content.  Additionally,
override the default ${PN}-[static]dev dependencies with the
correct pkgs.

Change-Id: I7c5a49a5cdd453cc23eb2595cc53455659040062
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb b/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb
index d92b905..24192d7 100644
--- a/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb
+++ b/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb
@@ -13,6 +13,10 @@
     ${PN}-bmc \
 "
 PACKAGES =+ "${STATE_MGR_PACKAGES}"
+PACKAGES_remove = "${PN}"
+RDEPENDS_${PN}-dev = "${STATE_MGR_PACKAGES}"
+RDEPENDS_${PN}-staticdev = "${STATE_MGR_PACKAGES}"
+
 DBUS_PACKAGES = "${STATE_MGR_PACKAGES}"
 
 # Set SYSTEMD_PACKAGES to empty because we do not want ${PN} and DBUS_PACKAGES