Set default restart policy for phosphor services

Reduce number of service restarts and increase wait
time between restarts.

- Change the StartLimitBurst to 3
Five just seems excessive for our services in openbmc.  In all fail
scenarios seen so far (other then with phosphor-hwmon), either
restarting once does the job or restarting all 5 times does not help
and we just end up hitting the 5 limit anyway.

- Change the RestartSec from 100ms to 1s.
When a service hits a failure, our new debug collection service kicks
in.  When a core file is involved, it's been found that generating 5 core
files within ~500ms puts a huge strain on the BMC.  Also, if the bmc is
going to get a fix on a restart of a service, the more time the better
(think retries on device driver scenarios).

Change-Id: I0e5bb3f32022cdb72d00f1a861a69653ef937cf1
Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
diff --git a/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend b/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
index 74a196d..1003e9e 100644
--- a/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
@@ -6,6 +6,7 @@
                         quotacheck kdbus ima smack polkit logind bootchart utmp"
 FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
 SRC_URI += "file://default.network"
+SRC_URI += "file://service-restart-policy.conf"
 SRC_URI += "file://0001-Export-message_append_cmdline.patch"
 SRC_URI += "file://0002-systemd-Make-pam-compile-shared-library.patch"
 SRC_URI += "file://0003-basic-Factor-out-string-checking-from-name_to_prefix.patch"
@@ -18,11 +19,13 @@
 
 RRECOMMENDS_${PN} += "obmc-targets"
 FILES_${PN} += "${libdir}/systemd/network/default.network"
+FILES_${PN} += "${libdir}/systemd/system.conf.d/service-restart-policy.conf"
 
 EXTRA_OECONF += " --disable-hwdb"
 
 do_install_append() {
         install -m 644 ${WORKDIR}/default.network ${D}${libdir}/systemd/network/
+        install -m 644 -D ${WORKDIR}/service-restart-policy.conf ${D}${libdir}/systemd/system.conf.d/service-restart-policy.conf
 
         #TODO Remove after this issue is resolved
         #https://github.com/openbmc/openbmc/issues/152