phosphor-ipmi-host: Move configuration to phosphor-ipmi-config

Witherspoon requires an dev_id.json file whose content is partially
derived from data provided by the os-release package. os-release is
updated for each commit, as some of its content (VERSION and
VERSION_ID) can be derived from `git describe`. As dev_id.json was
provided by the phosphor-ipmi-host package, every commit transitively
triggered a rebuild of phosphor-ipmi-host in order to satisfy
Witherspoon's requirements.

Always rebuilding phosphor-ipmi-host is unhelpful for several reasons:

* It needlessly reduces CI throughput, as it is likely the commits in
  question do not modify the phosphor-ipmi-host package.
* GCC suffers from what appears to be an unfixable[1] bug[2] that causes
  phoshor-ipmi-host to consume large (>5GiB) amounts of RAM when
  compiling some (at least Witherspoon) sensor configurations.

To avoid this, separate the configuration files out into
virtual/phosphor-ipmi-config and phosphor-ipmi-config packages that
phosphor-ipmi-host RDEPENDS on. Witherspoon provides an alternative
implementation in witherspoon-ipmi-config to mangle dev_id.json to its
particular requirements.

A virtual is used rather than a simple bbappends for Witherspoon, as the
bbappend approach breaks builds of machines other than Witherspoon if
Witherspoon is built first: The Witherspoon-specific dev_id.json file is
deployed in its mangled form into e.g. a Zaius image. Specifically, the
following sequence will trigger the issue:

    $ TEMPLATECONF=.../witherspoon.conf . openbmc-env
    $ bitbake obmc-phosphor-image
    $ rm -rf conf
    $ TEMPLATECONF=.../zaius.conf . openbmc-env
    $ bitbake obmc-phosphor-image

[1] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=80290#c26
[2] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=80290

Change-Id: Ib9629fc77b29e2deeab3f1c3a145d9e966c14ec4
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
index aeb1d50..f79974a 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
@@ -19,7 +19,6 @@
     whitelists = [ '{}-whitelist-native'.format(x) for x in whitelists ]
     return ' '.join(whitelists)
 
-
 DEPENDS += "autoconf-archive-native"
 DEPENDS += "nlohmann-json"
 DEPENDS += "obmc-targets"
@@ -34,6 +33,8 @@
 DEPENDS += "virtual/phosphor-ipmi-sensor-inventory"
 DEPENDS += "virtual/phosphor-ipmi-channel-config"
 
+VIRTUAL-RUNTIME_ipmi-config ?= "phosphor-ipmi-config"
+
 RDEPENDS_${PN}-dev += "phosphor-logging"
 RDEPENDS_${PN}-dev += "phosphor-mapper-dev"
 RDEPENDS_${PN} += "clear-once"
@@ -43,6 +44,7 @@
 RDEPENDS_${PN} += "phosphor-mapper"
 RDEPENDS_${PN} += "phosphor-time-manager"
 RDEPENDS_${PN} += "sdbusplus"
+RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_ipmi-config}"
 RDEPENDS_${PN} += "virtual/obmc-watchdog"
 
 SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service phosphor-ipmi-host.service"
@@ -68,13 +70,7 @@
 
 S = "${WORKDIR}/git"
 
-SRC_URI += "file://merge_yamls.py \
-            file://dev_id.json \
-            file://dcmi_cap.json \
-            file://power_reading.json \
-            file://dcmi_sensors.json \
-            file://cipher_list.json \
-            "
+SRC_URI += "file://merge_yamls.py "
 
 HOSTIPMI_PROVIDER_LIBRARY += "libapphandler.so"
 HOSTIPMI_PROVIDER_LIBRARY += "libsysintfcmds.so"
@@ -84,11 +80,6 @@
 FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
 FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
 FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
-FILES_${PN}_append = " ${datadir}/ipmi-providers/dev_id.json"
-FILES_${PN}_append = " ${datadir}/ipmi-providers/dcmi_cap.json"
-FILES_${PN}_append = " ${datadir}/ipmi-providers/power_reading.json"
-FILES_${PN}_append = " ${datadir}/ipmi-providers/dcmi_sensors.json"
-FILES_${PN}_append = " ${datadir}/ipmi-providers/cipher_list.json"
 FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
 
 # Soft Power Off
@@ -126,18 +117,6 @@
     # Invoke the script and don't catch any resulting exception.
     subprocess.check_call(cmd)
 }
-do_install_append(){
-    install -d ${D}${datadir}/ipmi-providers
-    install -m 0644 -D ${WORKDIR}/dev_id.json \
-        ${D}${datadir}/ipmi-providers/dev_id.json
-    install -m 0644 -D ${WORKDIR}/dcmi_cap.json \
-        ${D}${datadir}/ipmi-providers/dcmi_cap.json
-    install -m 0644 -D ${WORKDIR}/power_reading.json \
-        ${D}${datadir}/ipmi-providers/power_reading.json
-    install -m 0644 -D ${WORKDIR}/dcmi_sensors.json \
-        ${D}${datadir}/ipmi-providers/dcmi_sensors.json
-    install -m 0644 -D ${WORKDIR}/cipher_list.json \
-        ${D}${datadir}/ipmi-providers/cipher_list.json
-}
+
 # python-pyyaml-native is installed by do_configure, so put this task after
 addtask merge_sensors after do_configure before do_compile