meta-raspberrypi: subtree update:a953fc0f9b..e7c856ee7b

Allen Wild (1):
      conf/machine: add pci to MACHINE_FEATURES for Pi4

Andrei Gherzan (3):
      pi-bluetooth: Fix signature failures
      raspberrypi-tools: Update to current HEAD
      armstubs: Define the new symbols use in Makefile

Erik Botö (1):
      Add support for PiTFT 2.8" with capacitive touch

Martin Jansa (1):
      gstreamer1.0-plugins-base: respect opengl DISTRO_FEATURES when vc4graphics is in MACHINE_FEATURES

Pierre-Jean Texier (1):
      linux-raspberrypi: bump to Linux version 4.19.93

Ricardo Salveti (2):
      linux-raspberrypi: define kbuild defconfig for rpi cm3
      raspberrypi-cm3.conf: drop KBUILD_DEFCONFIG definition

Change-Id: Ie923657098eaf9733c7f6f73ee1f888174d44e5f
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend b/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend
index 9e86c00..29fcb0e 100644
--- a/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend
+++ b/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend
@@ -5,6 +5,7 @@
 
 PACKAGECONFIG_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' dispmanx', d)}"
 
-PACKAGECONFIG_GL_rpi = "egl gles2"
+PACKAGECONFIG_GL_VC4GRAPHICS = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}"
+PACKAGECONFIG_GL_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '${PACKAGECONFIG_GL_VC4GRAPHICS}', 'egl gles2', d)}"
 
 PACKAGECONFIG[dispmanx] = "--enable-dispmanx,--disable-dispmanx,userland"