phosphor-health-monitor: Add do_install in base recipe.

Added do_install in base recipe for phosphor-health-monitor to
copy the json file from WORKDIR to target for monitoring the CPU
and Memory usage of BMC. Therefore, this can be removed in each
bbappend files.

Tested: Tested in Facebook YosemiteV2 platform.

Signed-off-by: Jayashree Dhanapal <jayashree-d@hcl.com>
Change-Id: I78eed7efb3e0be81a952c4bc3c3ae64579a48f7d
diff --git a/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb b/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb
index 4c70253..a8aed2c 100644
--- a/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb
+++ b/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb
@@ -18,3 +18,10 @@
 
 inherit meson pkgconfig
 inherit systemd
+
+do_install:append() {
+  if [ -e "${WORKDIR}/bmc_health_config.json" ]; then
+    install -d ${D}${sysconfdir}/healthMon
+    install -m 0644 ${WORKDIR}/bmc_health_config.json ${D}${sysconfdir}/healthMon
+  fi
+}