Add recipe for phosphor-snmp

Phosphor-snmp provides the D-Bus service named network-snmp-conf
which is used to configure the snmp manager details.

Phosphor-snmp also provides the lib which is used by the client
to send the snmp trap.

Phosphor-snmp uses the net-snmp libs to send the trap.

net-snmp provides the following packages
net-snmp-libs,net-snmp-server, net-snmp-client,
net-snmp-server-snmpd-netsnmp-server-snmptrapd.

To send a trap we are interested only in the net-snmp-libs.
By default the net-snmp-libs is having the code enabled for server
sepcific functions which makes the libs heavy.

This commit adds the recipe for phosphor-snmp and the service file
for D-Bus service(network-snmp-conf) and disables those features
from net-snmp which are specfic for MIB parsing,snmpd and snmptrapd.

However this features may be required if we start using
the snmp agent functionality.

Change-Id: I6ff36fcd378db2f506b0621569693d66d7de79e9
Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
diff --git a/meta-phosphor/common/recipes-connectivity/net-snmp/net-snmp_%.bbappend b/meta-phosphor/common/recipes-connectivity/net-snmp/net-snmp_%.bbappend
new file mode 100644
index 0000000..03c5c88
--- /dev/null
+++ b/meta-phosphor/common/recipes-connectivity/net-snmp/net-snmp_%.bbappend
@@ -0,0 +1,13 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+EXTRA_OECONF += "--disable-mib-loading --disable-agent --disable-applications \
+--disable-manuals --disable-scripts --disable-mibs  --disable-embedded-perl \
+--disable-perl-cc-checks --disable-libtool-lock --disable-debugging \
+--disable-snmpv1 --disable-des --disable-privacy --disable-md5 \
+--disable-snmptrapd-subagent --disable-set-support --disable-deprecated"
+
+do_install_append() {
+    rm -f ${D}${libdir}/libnetsnmpmibs.so.*
+    rm -f ${D}${libdir}/libnetsnmphelpers.so.*
+    rm -f ${D}${libdir}/libnetsnmpagent.so.*
+}