Add recipe for phosphor-snmp

Phosphor-snmp provides the D-Bus service named network-snmp-conf
which is used to configure the snmp manager details.

Phosphor-snmp also provides the lib which is used by the client
to send the snmp trap.

Phosphor-snmp uses the net-snmp libs to send the trap.

net-snmp provides the following packages
net-snmp-libs,net-snmp-server, net-snmp-client,
net-snmp-server-snmpd-netsnmp-server-snmptrapd.

To send a trap we are interested only in the net-snmp-libs.
By default the net-snmp-libs is having the code enabled for server
sepcific functions which makes the libs heavy.

This commit adds the recipe for phosphor-snmp and the service file
for D-Bus service(network-snmp-conf) and disables those features
from net-snmp which are specfic for MIB parsing,snmpd and snmptrapd.

However this features may be required if we start using
the snmp agent functionality.

Change-Id: I6ff36fcd378db2f506b0621569693d66d7de79e9
Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/network/phosphor-snmp_git.bb b/meta-phosphor/common/recipes-phosphor/network/phosphor-snmp_git.bb
new file mode 100644
index 0000000..96e2448
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/network/phosphor-snmp_git.bb
@@ -0,0 +1,31 @@
+SUMMARY = "SNMP Manager Configuration"
+DESCRIPTION = "SNMP Manager Configuration."
+HOMEPAGE = "http://github.com/openbmc/phosphor-snmp"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+
+inherit autotools pkgconfig
+inherit pythonnative
+inherit obmc-phosphor-dbus-service
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/git/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI += "git://github.com/openbmc/phosphor-snmp"
+SRCREV = "3f6e2861d7291deea070336abb829c8538dcc7aa"
+
+DBUS_SERVICE_${PN} += "xyz.openbmc_project.Network.SNMP.service"
+
+DEPENDS += "systemd"
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
+DEPENDS += "phosphor-logging"
+DEPENDS += "net-snmp"
+
+RDEPENDS_${PN} += "libsystemd"
+RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
+RDEPENDS_${PN} += "phosphor-logging"
+RDEPENDS_${PN} += "net-snmp-libs"
+
+S = "${WORKDIR}/git"