meta-fii/meta-kudo: Fix power control states and timing

Summary of changes:
 1. Adjust start time of xyz.openbmc_project.State.Chassis.service
    to fix initial chassis state
 2. Add shutdown ack service
 3. Remove reset ack service
 4. Remove heartbeat mode
 5. Remove sysreset pin control from power_control.exe
 6. Remove all phosphor-fan services that caused power off during
    a system reset
 7. Adjustments to ampere_power_util.sh (See below)

ampere_power_util.sh:
 1. Use GPIO instead of dbus for host state
 2. Wait 3 seconds before checking power status for power on
 3. Wait 6 seconds before checking power status for power off
 4. Have force_off act GPIO while power_off sets Chassis state
 5. Graceful shutdown acts GPIO
 6. Check host status before issuing system reset
 7. Set Watchdog Expire Action to None before power off and reset

Signed-off-by: Charles Boyer <Charles.Boyer@fii-usa.com>
Change-Id: Ie2720ee60d489c4160165c6827a78a400ae4d30b
diff --git a/meta-fii/meta-kudo/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-fii/meta-kudo/recipes-phosphor/state/phosphor-state-manager_%.bbappend
new file mode 100644
index 0000000..57e3aa6
--- /dev/null
+++ b/meta-fii/meta-kudo/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -0,0 +1,11 @@
+FILESEXTRAPATHS:prepend:kudo := "${THISDIR}/${PN}:"
+
+SRC_URI:append:kudo = " \
+    file://xyz.openbmc_project.State.Chassis.service \
+    "
+
+do_install:append:kudo() {
+    install -d ${D}${systemd_system_unitdir}
+    install -m 0644 ${WORKDIR}/xyz.openbmc_project.State.Chassis.service ${D}${systemd_system_unitdir}/xyz.openbmc_project.State.Chassis.service
+}
+