Rainier power supply presence detects

Update rainier.conf to indicate the four power supply instances.

Update bbappend for Rainier SYSTEMD_LINK and SYSTEMD_ENVIRONMENT_FILE.

Add in subdirectory and power supply configuration files for GPIO
presence detect of the Rainier power supplies.

Use aspeed-gpio.sh from https://github.com/bradbishop/gpio-keys to
determine gpio-key values. Use 7-bit I2C addresses on BMC.

+-----+--------+----------+----+
| PSU | GPIO   | gpio-key | AA |
+-----+--------+----------+----+
| ps0 | GPIOS0 |    144   | 68 |
+-----+--------+----------+----+
| ps1 | GPIOS1 |    145   | 69 |
+-----+--------+----------+----+
| ps2 | GPIOS2 |    146   | 6a |
+-----+--------+----------+----+
| ps3 | GPIOS3 |    147   | 6b |
+-----+--------+----------+----+

(From meta-ibm rev: 3e8f174546cf440fda56ce47523030d4d403edbd)

Change-Id: Ia55f80e4d857e7a477385d73c12f9719e3065f95
Signed-off-by: Brandon Wyman <bjwyman@gmail.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
index 6919edf..04399f8 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
@@ -7,8 +7,10 @@
 
 SYSTEMD_LINK_${PN}-presence_append_ibm-ac-server = " ${@compose_list(d, 'FMT_POWERSUPPLY', 'OBMC_POWER_SUPPLY_INSTANCES')}"
 SYSTEMD_LINK_${PN}-presence_append_mihawk = " ${@compose_list(d, 'FMT_POWERSUPPLY', 'OBMC_POWER_SUPPLY_INSTANCES')}"
+SYSTEMD_LINK_${PN}-presence_append_rainier = " ${@compose_list(d, 'FMT_POWERSUPPLY', 'OBMC_POWER_SUPPLY_INSTANCES')}"
 
 POWERSUPPLY_ENV_FMT  = "obmc/gpio/phosphor-power-supply-{0}.conf"
 
 SYSTEMD_ENVIRONMENT_FILE_${PN}-presence_append_ibm-ac-server = " ${@compose_list(d, 'POWERSUPPLY_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"
 SYSTEMD_ENVIRONMENT_FILE_${PN}-presence_append_mihawk = " ${@compose_list(d, 'POWERSUPPLY_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"
+SYSTEMD_ENVIRONMENT_FILE_${PN}-presence_append_rainier = " ${@compose_list(d, 'POWERSUPPLY_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"