meta-phosphor: adjust IMAGE_NAME_SUFFIX use

OE-Core commit 26d97acc71379ab6702fa54a23b6542a3f51779c adjusted
how IMAGE_NAME_SUFFIX is used and expect it to no longer be present
in most of the image-conversion instructions.  Remove it as necessary
in our image bbclasses.

Tested: Bletchley successfully compiles with latest Yocto subtree
update.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Idaeff6134f2068a6671f4bf22fd0223f08963369
diff --git a/meta-phosphor/classes/fit-image.bbclass b/meta-phosphor/classes/fit-image.bbclass
index 7d23f44..d0c5183 100644
--- a/meta-phosphor/classes/fit-image.bbclass
+++ b/meta-phosphor/classes/fit-image.bbclass
@@ -2,8 +2,8 @@
 
 CONVERSIONTYPES += "fitImage"
 
-CONVERSION_CMD:fitImage = "run_assemble_fitimage ${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.${type}"
-INITRAMFS_IMAGE="${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.cpio.${INITRAMFS_CTYPE}"
+CONVERSION_CMD:fitImage = "run_assemble_fitimage ${IMAGE_NAME}.${type}"
+INITRAMFS_IMAGE="${IMAGE_NAME}.cpio.${INITRAMFS_CTYPE}"
 KERNEL_OUTPUT_DIR="${DEPLOY_DIR_IMAGE}"
 
 do_image_cpio[depends] += "virtual/kernel:do_deploy"