meta-phosphor: adjust IMAGE_NAME_SUFFIX use

OE-Core commit 26d97acc71379ab6702fa54a23b6542a3f51779c adjusted
how IMAGE_NAME_SUFFIX is used and expect it to no longer be present
in most of the image-conversion instructions.  Remove it as necessary
in our image bbclasses.

Tested: Bletchley successfully compiles with latest Yocto subtree
update.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Idaeff6134f2068a6671f4bf22fd0223f08963369
diff --git a/meta-phosphor/classes/image_types_phosphor.bbclass b/meta-phosphor/classes/image_types_phosphor.bbclass
index 70f285a..4f93999 100644
--- a/meta-phosphor/classes/image_types_phosphor.bbclass
+++ b/meta-phosphor/classes/image_types_phosphor.bbclass
@@ -92,6 +92,8 @@
 
 UBOOT_SUFFIX ?= "bin"
 
+IMAGE_NAME_SUFFIX=""
+
 python() {
     # Compute rwfs LEB count and LEB size.
     page_size = d.getVar('FLASH_PAGE_SIZE', True)