meta-google: kdump-ramoops: moving to private repo

Move gbmc ramoops collector into private repo.
This is to reduce the customized systemd script in public openbmc.

Change-Id: I9e8861fc2261852eb86b9b222749cb340ac66dad
Signed-off-by: Yuxiao Zhang <yuxiaozhang@google.com>
diff --git a/meta-google/recipes-google/systemd/gbmc-systemd-config.bb b/meta-google/recipes-google/systemd/gbmc-systemd-config.bb
index 7c644a2..37d73421 100644
--- a/meta-google/recipes-google/systemd/gbmc-systemd-config.bb
+++ b/meta-google/recipes-google/systemd/gbmc-systemd-config.bb
@@ -10,7 +10,6 @@
 SRC_URI:append = " \
   file://firmware-updates.target \
   file://firmware-updates-pre.target \
-  file://gbmc-log-ramoops.service \
   file://40-gbmc-forward.conf \
   file://40-gbmc-sysctl.conf \
   file://40-gbmc-time.conf \
@@ -34,9 +33,9 @@
 SYSTEMD_SERVICE:${PN}:append = " \
   firmware-updates.target \
   firmware-updates-pre.target \
-  gbmc-log-ramoops.service \
   "
 
+RDEPENDS:${PN}:append = " bash"
 # Put coredumps in the journal to ensure they stay in ram
 do_install() {
   install -d -m 0755 ${D}${systemd_unitdir}/coredump.conf.d
@@ -50,8 +49,6 @@
   install -d -m 0755 ${D}${systemd_system_unitdir}
   install -m 0644 ${WORKDIR}/firmware-updates.target ${D}${systemd_system_unitdir}/
   install -m 0644 ${WORKDIR}/firmware-updates-pre.target ${D}${systemd_system_unitdir}/
-  install -m 0644 ${WORKDIR}/gbmc-log-ramoops.service ${D}${systemd_system_unitdir}/
-
   # mask systemd-pstore.service to avoid copying logs to SPI
   mkdir -p ${D}${sysconfdir}/systemd/system
   ln -sv /dev/null ${D}${sysconfdir}/systemd/system/systemd-pstore.service