meta-facebook: obmc-console: Fix SoL with new design

With new design changes in obmc-console, config file needed changes
to follow design. Also created separate directorey for machine to
have machine specific config file.

Tested: Verified this with tiogapass and see ttyS2 service is launching.

(From meta-facebook rev: fc641dad18c84b391ce27da202a417f28d4da00b)

Change-Id: I811e8241fd40fa503aa9861894602344c85eba5f
Signed-off-by: Vijay Khemka <vijaykhemka@fb.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend b/meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend
index 24b52d7..06a91ce 100644
--- a/meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend
@@ -1,2 +1,13 @@
-FILESEXTRAPATHS_prepend_tiogapass := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/${MACHINE}:"
 OBMC_CONSOLE_HOST_TTY = "ttyS2"
+
+SRC_URI += "file://*.conf"
+SRC_URI_remove = "file://${BPN}.conf"
+
+do_install_append() {
+        # Install the server configuration
+        install -m 0755 -d ${D}${sysconfdir}/${BPN}
+        install -m 0644 ${WORKDIR}/*.conf ${D}${sysconfdir}/${BPN}/
+        # Remove upstream-provided server configuration
+        rm -f ${D}${sysconfdir}/${BPN}/server.ttyVUART0.conf
+}