Add API module for the machine readable workbook XML.

This recipe provides Targets.pm, which should be used
to parse the XML generated by the Serverwiz MRW tool.

Change-Id: I4d28f8b0dd2b8e3519c1ba007dfc9b77e83438f8
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb b/meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb
new file mode 100644
index 0000000..ec1df89
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Phosphor OpenBMC machine readable workbook API modules"
+DESCRIPTION = "The API for the MRW XML generated by the Serverwiz tool"
+PR = "r1"
+
+S = "${WORKDIR}/scripts"
+
+inherit obmc-phosphor-license
+inherit native
+inherit perlnative
+inherit cpan-base
+
+DEPENDS += "libxml-simple-perl-native json-perl-native"
+
+SRC_URI += "git://github.com/open-power/serverwiz.git;subpath=scripts"
+SRCREV = "04f15f37e9ab6c09412a0abcffb87e9aefcc5368"
+
+do_install() {
+    install -d ${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw
+    install -m 0755 Targets.pm ${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw/Targets.pm
+}