gtest, gmock: update 1.7.0 -> 1.8.0

Starting from the 1.8.0 release, GoogleTest and GoogleMock are
maintained in the same repository and released together. Update the
gtest recipe to PROVIDE gmock (and drop the gmock recipe).

Patches to add CMake install rules have been dropped (now supported
upstream).

  https://github.com/google/googletest/commit/98d988deac06637364f6cd41c45c3db4a8a0b6bc
  https://github.com/google/googletest/commit/7c8ac4886a7ad513430d132c446a93c6d395345a

Change-Id: I5de909fd9336f9683feb74e409c3716ec0aa2474
Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
(cherry picked from commit 1e2491d12520d767e0e5687a9b15819fe0b6ff27)
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-test/gtest/gtest_1.8.0.bb b/import-layers/meta-openembedded/meta-oe/recipes-test/gtest/gtest_1.8.0.bb
new file mode 100644
index 0000000..483dc1f
--- /dev/null
+++ b/import-layers/meta-openembedded/meta-oe/recipes-test/gtest/gtest_1.8.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Google's framework for writing C++ tests"
+HOMEPAGE = "https://github.com/google/googletest"
+SECTION = "libs"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://googlemock/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
+                    file://googletest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a"
+
+PROVIDES += "gmock"
+
+SRC_URI = "\
+    https://github.com/google/googletest/archive/release-${PV}.tar.gz \
+    file://Add-pkg-config-support.patch \
+"
+
+SRC_URI[md5sum] = "16877098823401d1bf2ed7891d7dce36"
+SRC_URI[sha256sum] = "58a6f4277ca2bc8565222b3bbd58a177609e9c488e8a72649359ba51450db7d8"
+
+S = "${WORKDIR}/googletest-release-${PV}"
+
+inherit cmake
+
+ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY_${PN}-dbg = "1"
+
+RDEPENDS_${PN}-dev += "${PN}-staticdev"
+
+BBCLASSEXTEND = "native nativesdk"