Add virtual/phosphor-logging-callouts

This virtual generates mappings between sysfs device paths and inventory
items.

Add a native recipe that builds the configuration from MRW. Set this
recipe as the default for OpenPOWER systems.

Resolves openbmc/openbmc#1093
Resolves openbmc/openbmc#1249

Change-Id: If67b4ef0850910a076ca212197a4bd0e704d0266
Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb b/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb
new file mode 100644
index 0000000..f76d202
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Generated callout information for phosphor-logging"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-logging
+
+SRC_URI += "file://callouts.yaml"
+
+PROVIDES += "virtual/phosphor-logging-callouts"
+
+S = "${WORKDIR}"
+
+do_install() {
+        DEST=${D}${callouts_datadir}
+        install -d ${DEST}
+        install callouts.yaml ${DEST}
+}