meta-security: subtree update:30ea7a89dc..d75dc96fa3

Armin Kuster (11):
      python-scapy: drop py2 package
      packagegroup-core-security-ptest: only included if ptest is enabled
      packagegroup-core-security: update package name
      busybox: fix sig changes when layer added
      initramfs-framework-ima: correct IMA_POLICY name
      apparmor: drop lsb RDEPENDS
      openscap: Drop nostamp
      scap-security-guide: add depends on openscap-native do_install
      cryptsetup-tpm-incubator: fix QA error RDEPENDS
      oe-scap: Fix QA RDEPENDS error
      suricata: update to 4.1.4

Stefan Agner (1):
      libseccomp: build static library always

Change-Id: Ia2f8aec978de4f3d20c13be3c12b70a7badc29d5
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-security/recipes-security/scapy/python3-scapy_2.4.3.bb b/meta-security/recipes-security/scapy/python3-scapy_2.4.3.bb
index abcaeeb..925f188 100644
--- a/meta-security/recipes-security/scapy/python3-scapy_2.4.3.bb
+++ b/meta-security/recipes-security/scapy/python3-scapy_2.4.3.bb
@@ -1,9 +1,30 @@
-inherit setuptools3
-require python-scapy.inc
+SUMMARY = "Network scanning and manipulation tool"
+DESCRIPTION = "Scapy is a powerful interactive packet manipulation program. It is able to forge or decode packets of a wide number of protocols, send them on the wire, capture them, match requests and replies, and much more. It can easily handle most classical tasks like scanning, tracerouting, probing, unit tests, attacks or network discovery (it can replace hping, 85% of nmap, arpspoof, arp-sk, arping, tcpdump, tethereal, p0f, etc.). It also performs very well at a lot of other specific tasks that most other tools can't handle, like sending invalid frames, injecting your own 802.11 frames, combining technics (VLAN hopping+ARP cache poisoning, VOIP decoding on WEP encrypted channel, ...), etc."
+SECTION = "security"
+LICENSE = "GPLv2"
 
-SRC_URI += "file://run-ptest"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+S = "${WORKDIR}/git"
+
+SRCREV = "3047580162a9407ef05fe981983cacfa698f1159"
+SRC_URI = "git://github.com/secdev/scapy.git \
+           file://run-ptest"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3 ptest
 
 do_install_append() {
         mv ${D}${bindir}/scapy ${D}${bindir}/scapy3
         mv ${D}${bindir}/UTscapy ${D}${bindir}/UTscapy3
 }
+
+do_install_ptest() {
+    install -m 0644 ${S}/test/regression.uts ${D}${PTEST_PATH}
+    sed -i 's,@PTEST_PATH@,${PTEST_PATH},' ${D}${PTEST_PATH}/run-ptest
+}
+
+RDEPENDS_${PN} = "tcpdump ${PYTHON_PN}-compression ${PYTHON_PN}-cryptography ${PYTHON_PN}-netclient  \
+                  ${PYTHON_PN}-netserver ${PYTHON_PN}-pydoc ${PYTHON_PN}-pkgutil ${PYTHON_PN}-shell \
+                  ${PYTHON_PN}-threading ${PYTHON_PN}-numbers ${PYTHON_PN}-pycrypto"