meta-ampere: handle Overtemp Fault LED

Assert Fault LED when detecting OVERTEMP signal asserted.
This is done by adding new overtemp_fault LED group and
update the overtemp service to assert/de-assert the LED
group.

1. Start the ampere_overtemp@.service
2. Verify that the `Fault Led` is turned on and turn off after 10s.
3. Verify that Thermal Trip SEL is created.

Signed-off-by: Hieu Huynh <hieuh@os.amperecomputing.com>
Change-Id: Ifbc203bf79a13741082d84850b9e75ca6148a6cd
diff --git a/meta-ampere/meta-common/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend b/meta-ampere/meta-common/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
index f8cf1d4..fb411e0 100644
--- a/meta-ampere/meta-common/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
+++ b/meta-ampere/meta-common/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
@@ -1,5 +1,9 @@
 FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
 
+SRC_URI += " \
+           file://ampere_overtemp.sh \
+           "
+
 SYSTEMD_SERVICE:${PN}-monitor += " \
                                   ampere-host-shutdown-ack@.service \
                                   ampere_overtemp@.service \
@@ -7,5 +11,13 @@
                                   ampere_hightemp_stop@.service \
                                  "
 
+FILES:${PN}-monitor += " \
+                        /usr/sbin/ampere_overtemp.sh \
+                       "
+
 SYSTEMD_LINK:${PN}-monitor:append = " ../phosphor-multi-gpio-monitor.service:multi-user.target.requires/phosphor-multi-gpio-monitor.service"
 
+do_install:append() {
+    install -d ${D}/usr/sbin
+    install -m 0755 ${WORKDIR}/ampere_overtemp.sh ${D}/${sbindir}/
+}