Remove ipmi distro feature, virtual

We don't need a distro feature for net IPMI at this point, so
simplify things a bit.

Additionally, remove the net-ipmi virtual since we don't have
any alternative implementations today and it just adds unnecessary
complexity.

Tested: Built a witherspoon image and validated manifest
Change-Id: I2784f13b3e8897e855ac128422081ec3ee207bf1
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/classes/obmc-phosphor-image.bbclass b/meta-phosphor/classes/obmc-phosphor-image.bbclass
index ab72deb..a4aaeae 100644
--- a/meta-phosphor/classes/obmc-phosphor-image.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-image.bbclass
@@ -37,7 +37,7 @@
 FEATURE_PACKAGES_obmc-inventory ?= "packagegroup-obmc-apps-inventory"
 FEATURE_PACKAGES_obmc-leds ?= "packagegroup-obmc-apps-leds"
 FEATURE_PACKAGES_obmc-logging-mgmt ?= "${@df_enabled(d, 'obmc-logging-mgmt', 'packagegroup-obmc-apps-logging')}"
-FEATURE_PACKAGES_obmc-net-ipmi ?= "${@df_enabled(d, 'obmc-net-ipmi', 'virtual-obmc-net-ipmi')}"
+FEATURE_PACKAGES_obmc-net-ipmi ?= "phosphor-ipmi-net"
 FEATURE_PACKAGES_obmc-sensors ?= "packagegroup-obmc-apps-sensors"
 FEATURE_PACKAGES_obmc-software ?= "packagegroup-obmc-apps-software"
 FEATURE_PACKAGES_obmc-system-mgmt ?= "${@df_enabled(d, 'obmc-phosphor-system-mgmt', 'virtual-obmc-system-mgmt')}"
@@ -46,6 +46,11 @@
 FEATURE_PACKAGES_obmc-network-mgmt ?= "packagegroup-obmc-apps-network"
 FEATURE_PACKAGES_obmc-user-mgmt ?= "packagegroup-obmc-apps-user-mgmt"
 
+# FIXME: phosphor-net-ipmi depends on phosphor-ipmi-host !?!? and
+# cannot be built on core-qemu machines because of the dependency
+# tree under phosphor-ipmi-host
+FEATURE_PACKAGES_obmc-net-ipmi_qemuall = ""
+
 # Install entire Phosphor application stack by default
 IMAGE_FEATURES += " \
         obmc-bmc-state-mgmt \