blob: 3fdcfd81a4b793cec999730118c6c42c96675002 [file] [log] [blame]
SUMMARY = "GNOME session"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = " \
glib-2.0-native \
libxslt-native \
xmlto-native \
xtrans \
libice \
libsm \
virtual/libx11 \
gtk+3 \
gnome-desktop3 \
gsettings-desktop-schemas \
json-glib \
"
GNOMEBASEBUILDCLASS = "meson"
inherit gnomebase gettext gsettings upstream-version-is-even features_check
REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam gobject-introspection-data"
SRC_URI[archive.md5sum] = "cd23e30c4991ca1f477020c67ea3a540"
SRC_URI[archive.sha256sum] = "d54b38b818c812f64b82cc6a1279e3ca5a6e391ee662793322a38cab5670bb7a"
PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', 'consolekit',d)}"
PACKAGECONFIG[consolekit] = "-Dconsolekit=true, -Dconsolekit=false, consolekit"
PACKAGECONFIG[systemd] = "-Dsystemd=true -Dsystemd_journal=true, -Dsystemd=false -Dsystemd_journal=false, systemd"
FILES:${PN} += " \
${datadir}/xsessions \
${datadir}/wayland-sessions \
${systemd_user_unitdir} \
"
RDEPENDS:${PN} += "gnome-shell gnome-settings-daemon gsettings-desktop-schemas"