blob: af3879372b687c1cdceadd4d4b8ce6e0a428da1e [file] [log] [blame]
inherit image_types
CONVERSIONTYPES += "sparse"
CONVERSION_CMD:sparse() {
in="${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.${type}"
out="${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.${type}.sparse"
case "${type}" in
ext*)
ext2simg "$in" "$out"
;;
*)
img2simg "$in" "$out"
;;
esac
}
CONVERSION_DEPENDS_sparse = "android-tools-native"