blob: ea47ad2eb97b73d5f50a2ea351498dfb2c6002fd [file] [log] [blame]
SUMMARY = "Async http client/server framework"
DESCRIPTION = "Asynchronous HTTP client/server framework for asyncio and Python"
HOMEPAGE = "https://github.com/aio-libs/aiohttp"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3bf3d48554bdca1ea7fdb48de378c2ca"
SRC_URI[sha256sum] = "493d3299ebe5f5a7c66b9819eacdcfbbaaf1a8e84911ddffcdc48888497afecf"
PYPI_PACKAGE = "aiohttp"
inherit setuptools3 pypi
RDEPENDS:${PN} = "\
${PYTHON_PN}-async-timeout \
${PYTHON_PN}-attrs \
${PYTHON_PN}-chardet \
${PYTHON_PN}-html \
${PYTHON_PN}-idna-ssl \
${PYTHON_PN}-json \
${PYTHON_PN}-misc \
${PYTHON_PN}-multidict \
${PYTHON_PN}-netserver \
${PYTHON_PN}-typing-extensions \
${PYTHON_PN}-yarl \
"