blob: 39fe4b9b7a8be441901fe2e8d21f389a505577e4 [file] [log] [blame]
SUMMARY = "Sensors plugin for the Xfce Panel"
HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b94789bed9aec03b9656a9cc5398c706"
inherit xfce-panel-plugin
SRC_URI[sha256sum] = "83c64ae4618dd592971cfa0bc285a9b47af801a3ed856835cdb2a4c533c7846c"
SRC_URI += "file://0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch"
EXTRA_OECONF = " \
--disable-procacpi \
--disable-xnvctrl \
"
do_configure:prepend() {
sed -i 's:LIBSENSORS_CFLAGS=.*:LIBSENSORS_CFLAGS=-I${STAGING_INCDIR}:g' ${S}/configure.ac
}
PACKAGECONFIG[libsensors] = "--enable-libsensors,--disable-libsensors, lmsensors"
PACKAGECONFIG[hddtemp] = "--enable-hddtemp,--disable-hddtemp, hddtemp"
PACKAGECONFIG[netcat] = "--enable-netcat,--disable-netcat, netcat"
PACKAGECONFIG[libnotify] = "--enable-notification,--disable-notification, libnotify"
FILES_SOLIBSDEV = "${libdir}/xfce4/modules/lib*${SOLIBSDEV}"