blob: c5ab85dd08cee4cc7e88ac9afc6cab9e370214ff [file] [log] [blame]
DESCRIPTION = "Thumbnail service implementing the thumbnail management D-Bus specification"
SECTION = "x11/libs"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "freetype gdk-pixbuf poppler curl xfce4-dev-tools-native libxml2 libgsf"
inherit xfce gtk-doc
SRC_URI[sha256sum] = "9b0b7fed0c64041733d490b1b307297984629d0dd85369749617a8766850af66"
INSANE_SKIP:${PN} = "dev-so"
PACKAGECONFIG ??= ""
PACKAGECONFIG[gstreamer-thumbnailer] = "--enable-gstreamer-thumbnailer,--disable-gstreamer-thumbnailer,gstreamer1.0 gstreamer1.0-plugins-base"
do_install:append() {
# Makefile seems to race on creation of symlink. So ensure creation here
# until fixed properly
ln -sf tumbler-xdg-cache.so ${D}${libdir}/tumbler-1/plugins/cache/tumbler-cache-plugin.so
}
FILES:${PN} += "${datadir}/dbus-1/services \
${libdir}/tumbler-1/tumblerd \
${libdir}/tumbler-1/plugins/*.so \
${libdir}/tumbler-1/plugins/cache/*.so \
"
FILES:${PN}-dev += "${libdir}/tumbler-1/plugins/*.la \
${libdir}/tumbler-1/plugins/cache/*.la \
"