meta-nicole: u-boot: add bmc position support

This brings:
 - GPIO support in u-boot
 - BMC position is determined by the GPIOE1 and stored as a boot
   argument.

(From meta-yadro rev: 1b68cd934fe58ce3c33b272b45497d2a1b4e35e6)

Change-Id: Ieaf5bda2267b533327618330760431e66224092a
End-User-Impact: In the u-boot shell now available `gpio` command
Signed-off-by: Alexander Filippov <a.filippov@yadro.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-yadro/meta-nicole/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend b/meta-yadro/meta-nicole/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
index bf7802a..1390922 100644
--- a/meta-yadro/meta-nicole/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
+++ b/meta-yadro/meta-nicole/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
@@ -3,4 +3,6 @@
 SRC_URI_append = " \
     file://0001-Add-system-reset-status-support.patch \
     file://0002-config-ast-common-set-fieldmode-to-true.patch \
+    file://0003-aspeed-add-gpio-support.patch \
+    file://0004-aspeed-add-bmc-position-support.patch \
     "