blob: 6ce45ca6ee117e07edb1ccd2e7047e9f0fd5686a [file] [log] [blame]
DESCRIPTION = "Modern password hashing for your software and your servers."
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
HOMEPAGE = "https://pypi.org/project/bcrypt/"
DEPENDS += "${PYTHON_PN}-cffi-native"
SRC_URI[sha256sum] = "27d375903ac8261cfe4047f6709d16f7d18d39b1ec92aaf72af989552a650ebd"
inherit pypi python_setuptools3_rust ptest cargo-update-recipe-crates
SRC_URI += " \
file://run-ptest \
"
require ${BPN}-crates.inc
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
}
RDEPENDS:${PN}:class-target += "\
${PYTHON_PN}-cffi \
${PYTHON_PN}-ctypes \
${PYTHON_PN}-shell \
${PYTHON_PN}-six \
"