blob: 9631f59288384f4d8b51b4adac3c6303199c076c [file] [log] [blame]
SUMMARY = "World timezone definitions, modern and historical"
HOMEPAGE = "http://pythonhosted.org/pytz"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999"
inherit pypi setuptools3 ptest
SRC_URI[sha256sum] = "e89512406b793ca39f5971bc999cc538ce125c0e51c27941bef4568b460095e2"
RDEPENDS:${PN}:class-target += "\
${PYTHON_PN}-datetime \
${PYTHON_PN}-doctest \
${PYTHON_PN}-io \
${PYTHON_PN}-pickle \
${PYTHON_PN}-pprint \
${PYTHON_PN}-threading \
"
BBCLASSEXTEND = "native nativesdk"
SRC_URI += " \
file://run-ptest \
"
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/pytz
install -d ${D}${PTEST_PATH}/pytz/tests
cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
cp -f ${S}/README.rst ${D}${PTEST_PATH}/
}