subtree updates july 21 2023 pi,security,arm

meta-arm: d6fac49541..b4d50a273d:
  Abdellatif El Khlifi (5):
        arm-bsp/documentation: corstone1000: Update change log
        arm-bsp/doc: corstone1000: Update the software architecture document
        arm-bsp/documentation: corstone1000: update the release note
        arm-bsp/documentation: corstone1000: update user guide
        kas: set the SHAs for 2023.06 release

  Jon Mason (7):
        arm/optee-test: modify to use build openssl
        arm/optee: update to 3.22.0
        arm-bsp/machine: work around rootfs name issue
        ci/clang: add llvm-native from clang README
        arm/optee-os: update/clean-up patches and recipes
        arm-bsp/juno: remove commented out KCONFIG
        arm/linux-yocto: move 6.1 patches to a unique bbappend

  Khem Raj (1):
        gn: Disable warning as error but not disable completely

  Mikko Rapeli (1):
        optee-os optee-test: switch from SRC_URI:append to SRC_URI +=

  Peter Hoyes (5):
        runfvp: Add missing conffile include
        arm/oeqa: Merge all OEFVP*Target classes
        arm/OEFVPTarget: Add support for model state transitions
        arm/oeqa: Convert linuxboot test case into fvp_boot
        arm/oeqa: Introduce the fvp_devices test suite

  Ross Burton (14):
        CI: use Kas 3.3
        CI: update to Kas format 14
        CI: use branch, not refspec
        CI: generate and use a Kas lock file
        CI: add a tool to fetch a lockfile.yml for a specified build
        arm/scp-firmware: set default SCP_PLATFORM to MACHINE
        arm-bsp/scp-firmware: remove redundant SCP_PLATFORM
        arm/scp-firware: update compiler variables
        arm/scp-firmware: log what platform/firmware/type is being built
        arm/scp-firmware: fix intermittent compile failures
        CI: track master
        arm-bsp/u-boot: add temporary 2023.01 recipe
        toolchain: remove pointless provides
        arm-bsp/linux-yocto: fix Upstream-Status

  Rouven Czerwinski (3):
        optee-os: add optional optee-os-ta package
        optee-os: deploy ta elf files
        optee-test: add TA elfs to deploydir

  Tomás González (2):
        arm-bsp/documentation: corstone1000: Update the user guide
        arm-bsp/documentation: corstone1000: Update the release notes

  Ziad Elhanafy (5):
        arm-bsp/conf: Remove hardcoded .rootfs from image path
        arm/classes: Remove IMAGE_NAME_SUFFIX from image path
        arm: Set FVP EULA environment variable details message
        kas: Add fvp-eula.yml and remove license related settings
        arm-bsp/documentation: Replace FVP_BASE_R_ARM_EULA_ACCEPT with ARM_FVP_EULA_ACCEPT

meta-raspberrypi: dff85b9a9f..e3f733cadd:
  Khem Raj (1):
        linux-raspberrypi_6.1.bb: Update to 6.1.38
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: Iebdd94d49998e9297e49ee2463761f2f3acb45c1
diff --git a/meta-arm/meta-arm/recipes-bsp/scp-firmware/scp-firmware_2.12.0.bb b/meta-arm/meta-arm/recipes-bsp/scp-firmware/scp-firmware_2.12.0.bb
index 2be5b30..58482cd 100644
--- a/meta-arm/meta-arm/recipes-bsp/scp-firmware/scp-firmware_2.12.0.bb
+++ b/meta-arm/meta-arm/recipes-bsp/scp-firmware/scp-firmware_2.12.0.bb
@@ -7,16 +7,16 @@
                     file://contrib/cmsis/git/LICENSE.txt;md5=e3fc50a88d0a364313df4b21ef20c29e"
 
 SRC_URI_SCP_FIRMWARE ?= "gitsm://github.com/ARM-software/SCP-firmware.git;protocol=https"
-SRC_URI = "${SRC_URI_SCP_FIRMWARE};branch=${SRCBRANCH}"
-SRCBRANCH = "master"
+SRC_URI = "${SRC_URI_SCP_FIRMWARE};branch=${SRCBRANCH} \
+           file://optee-private-includes.patch"
 
+SRCBRANCH = "master"
 SRCREV  = "0c7236b1851d90124210a0414fd982dc55322c7c"
 
 PROVIDES += "virtual/control-processor-firmware"
 
 CMAKE_BUILD_TYPE    ?= "RelWithDebInfo"
-SCP_PLATFORM        ?= "invalid"
-SCP_COMPILER        ?= "arm-none-eabi"
+SCP_PLATFORM        ?= "${MACHINE}"
 SCP_LOG_LEVEL       ?= "WARN"
 SCP_PLATFORM_FEATURE_SET ?= "0"
 
@@ -53,12 +53,14 @@
                  -D SCP_LOG_LEVEL=${SCP_LOG_LEVEL} \
                  -D SCP_PLATFORM_FEATURE_SET=${SCP_PLATFORM_FEATURE_SET} \
                  -D DISABLE_CPPCHECK=1 \
+                 -D SCP_TOOLCHAIN=GNU \
                 "
 
 do_configure() {
     for FW in ${FW_TARGETS}; do
         for TYPE in ${FW_INSTALL}; do
-            cmake -GNinja ${EXTRA_OECMAKE} -S ${S} -B "${B}/${TYPE}/${FW}" -D SCP_FIRMWARE_SOURCE_DIR="${SCP_PLATFORM}/${FW}_${TYPE}"
+            bbnote Configuring ${SCP_PLATFORM}/${FW}_${TYPE}...
+            cmake -GNinja ${EXTRA_OECMAKE} -S ${S} -B "${B}/${TYPE}/${FW}" -D SCP_FIRMWARE_SOURCE_DIR:PATH="${SCP_PLATFORM}/${FW}_${TYPE}"
         done
     done
 }
@@ -68,6 +70,7 @@
 do_compile() {
     for FW in ${FW_TARGETS}; do
         for TYPE in ${FW_INSTALL}; do
+            bbnote Building ${SCP_PLATFORM}/${FW}_${TYPE}...
             VERBOSE=1 cmake --build ${B}/${TYPE}/${FW} --target all
         done
     done