software-manager-mmc: Use zstd instead of zstd-bin

The commit meta-openembedded: subtree update:98175fd0cc..da393545a2
removed the zstd recipe (zstd_1.4.5.bb) from meta-openembedded and just
left the one in oe-core (zstd_1.4.9.bb):

Randy MacLeod (6):
      zstd: remove the recipe since it moved to oe-core

The 1.4.5 recipe had a change to split the binaries by adding "inherit
lib_package" to the recipe, but this change is not present in 1.4.9.

We'll need to check for any zstd changes in future poky updates since the
person that made the change to split the binaries in meta-openembedded
might make a submission to port that change into the oe-core recipe.

Even though this change will compile, it would break firmware updates on
Rainier because only the zstd libraries would be installed and not the
binaries. Therefore this commit must be submitted at the same time as the
meta-openembedded subtree update.

Change-Id: Ie7246195f5db42a1a0c402643439d312ad058a80
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/meta-phosphor/classes/phosphor-software-manager-mmc.bbclass b/meta-phosphor/classes/phosphor-software-manager-mmc.bbclass
index d4eb381..f30f0c0 100644
--- a/meta-phosphor/classes/phosphor-software-manager-mmc.bbclass
+++ b/meta-phosphor/classes/phosphor-software-manager-mmc.bbclass
@@ -9,7 +9,7 @@
 RDEPENDS_phosphor-software-manager-updater-mmc += " \
     gptfdisk \
     parted \
-    zstd-bin \
+    zstd \
 "
 
 SYSTEMD_SERVICE_phosphor-software-manager-updater-mmc += " \