phosphor-state-manager: enable new chassis log on poweron

Make this the default for all who are enabling the chassis feature from
PSM on their systems.

Tested:
- Confirmed new service was built into p10bmc image

Change-Id: I86364a4204747fe0cde161c0d44a619ec53b6785
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
index 61e325d..b7ba29b 100644
--- a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
@@ -46,6 +46,10 @@
 # The obmc-targets are the base targets required to boot a computer system
 RRECOMMENDS:${PN}-host += "${PN}-obmc-targets"
 
+# Make it the default to create an info log when the chassis transitions
+# from off to on
+RRECOMMENDS:${PN}-chassis:append = " ${PN}-chassis-poweron-log"
+
 inherit meson pkgconfig
 inherit obmc-phosphor-dbus-service
 inherit obmc-phosphor-systemd