slpd-lite:Create Recipe

-Create the slpd-lite.conf through the bbclass
-Create the service file which starts the slpd

Change-Id: I10b23bb81492270337e02470c75094eff30b4190
Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/slpd-lite/slpd-lite.bb b/meta-phosphor/common/recipes-phosphor/slpd-lite/slpd-lite.bb
new file mode 100644
index 0000000..0f3ac5c
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/slpd-lite/slpd-lite.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Lightweight SLP Server"
+DESCRIPTION = "Lightweight Unicast-only SLP Server"
+HOMEPAGE = "http://github.com/openbmc/slpd-lite"
+PR = "r1"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-license
+inherit obmc-phosphor-systemd
+
+SYSTEMD_SERVICE_${PN} += "slpd-lite.service"
+
+DEPENDS += "systemd"
+DEPENDS += "autoconf-archive-native"
+
+SRC_URI += "git://github.com/openbmc/slpd-lite"
+
+SRCREV = "70b8527104281ffd927c087480fbe1168a75fe93"
+
+S = "${WORKDIR}/git"