blob: d414bc683fb976f6526d7d8c6a59b1db9e1c16ee [file] [log] [blame]
SUMMARY = "display dialog boxes from shell scripts"
DESCRIPTION = "Dialog lets you to present a variety of questions \
or display messages using dialog boxes from a shell \
script (or any scripting language)."
HOMEPAGE = "http://invisible-island.net/dialog/"
SECTION = "console/utils"
DEPENDS = "ncurses"
LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
SRC_URI = "ftp://ftp.invisible-island.net/${BPN}/${BP}.tgz \
"
SRC_URI[md5sum] = "e9d7f8b5e7b17183b0fb9297c0f57840"
SRC_URI[sha256sum] = "e5eb0eaaef9cae8c822887bd998e33c2c3b94ebadd37b4f6aba018c0194a2a87"
# hardcoded here for use in dialog-static recipe
S = "${WORKDIR}/dialog-${PV}"
inherit autotools-brokensep pkgconfig
EXTRA_OECONF = "--with-ncurses \
--disable-rpath-hack"
do_configure() {
gnu-configize --force
sed -i 's,${cf_ncuconfig_root}6-config,${cf_ncuconfig_root}-config,g' -i configure
sed -i 's,cf_have_ncuconfig=unknown,cf_have_ncuconfig=yes,g' -i configure
oe_runconf
}