blob: 74f1800d18f1c3eefa06525a3e2d605b235f51ab [file] [log] [blame]
DESCRIPTION = "The goal of this project is to provide a tiny library that would \
facilitate the common operations with sizes in bytes."
HOMEPAGE = "https://github.com/rhinstaller/libbytesize"
LICENSE = "LGPLv2+"
SECTION = "devel/lib"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
S = "${WORKDIR}/git"
B = "${S}"
SRCREV = "92c00638a6f846df5c40dbb690f9fcf998ad6df2"
SRC_URI = "git://github.com/rhinstaller/libbytesize;branch=master \
file://0001-fix-out-of-tree-build-failure.patch \
"
inherit gettext autotools python3native
DEPENDS += " \
libpcre2 \
gmp \
mpfr \
gettext-native \
"
FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/bytesize"
PACKAGECONFIG ??= "python3"
PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3-core"
PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
EXTRA_OEMAKE = "py3libdir=${PYTHON_SITEPACKAGES_DIR}"