blob: cc07dcb06ec15eedcf9c4c4e2631b19d53f8b253 [file] [log] [blame]
DESCRIPTION = "Satyr is a collection of low-level algorithms for program \
failure processing, analysis, and reporting supporting kernel space, user \
space, Python, and Java programs"
HOMEPAGE = "https://github.com/abrt/satyr"
LICENSE = "GPLv2"
inherit autotools-brokensep python3native pkgconfig
SRC_URI = "git://github.com/abrt/satyr.git \
file://0002-fix-compile-failure-against-musl-C-library.patch \
"
SRCREV = "dff1b877d42bf2153f8f090905d9cc8fb333bf1e"
S = "${WORKDIR}/git"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
DEPENDS += " \
gdb \
"
PACKAGES += "python3-${BPN}"
FILES_python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
PACKAGECONFIG ??= "python3 rpm"
PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"
PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm"
do_configure_prepend() {
${S}/gen-version
}