meta-raspberrypi: subtree update:09a3c11696..3a1fec22c0

Jan-Simon Moeller (1):
      python3-sense-hat: Switch to using pillow instead of imaging module

Jose Quaresma (3):
      gstreamer1.0-plugins-good: add package config knob to enable rpicamsrc plugin
      gstreamer1.0-plugins-good: enable rpicamsrc plugin
      gstreamer1.0-plugins-base: drop custom cppflags

Khem Raj (9):
      linux-raspberrypi: Do not use += with append
      python3-sense-hat: Move to dynamic-layers
      layer.conf: Add hardknott (3.3) to acceptable releases
      linux-raspberrypi_5.4.bb: Update to 5.4.79
      raspberrypi-firmware: Update to latest to take 5.4.79 prebuilts
      userland: Upgrade to latest as of 20201027
      raspberrypi-tools: Update to latest on master
      armstubs: Always use gcc compiler
      packagegroup-rpi-test: Add python3-sense-hat in a meta-python specific bbappend

Madhavan Krishnan (1):
      libcamera: Enabled camera overlays define based

Martin Jansa (3):
      gstreamer1.0-omx: rename bbappend to match new 1.18.0 version from oe-core
      layer.conf: Remove older releases from LAYERSERIES_COMPAT
      Revert "gstreamer1.0-plugins-good: add package config knob to enable rpicamsrc plugin"

Ming Liu (1):
      rpi-u-boot-scr: drop hard-coded 'arm'

Paul Barker (9):
      linux-raspberrypi: Convert dynamic config patching to config fragments
      sdcard_image-rpi: Drop redundant dependency on rpi-config:do_deploy
      rpi-cmdline: Move cmdline.txt generation to a separate recipe
      bootfiles: Use BOOTFILES_DIR_NAME variable
      rpi-bootfiles: Rename recipe to avoid ambiguity
      linux-raspberrypi: Remove obsolete kernel versions
      linux-raspberrypi: Drop unused rpi-kernel-misc config fragment
      linux-raspberrypi: Merge v5.4 recipe & inc file
      linux-raspberrypi-dev: Update for testing v5.10.y

Trevor Woerner (1):
      userland: add knob for ALL_APPS

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I90e0cba993e7f5bae2e56f2d40fd2f69211c2648
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-cmdline.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-cmdline.bb
new file mode 100644
index 0000000..97db4e3
--- /dev/null
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-cmdline.bb
@@ -0,0 +1,49 @@
+SUMMARY = "cmdline.txt file used to boot the kernel on a Raspberry Pi device"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+COMPATIBLE_MACHINE = "^rpi$"
+INHIBIT_DEFAULT_DEPS = "1"
+inherit deploy nopackages
+
+CMDLINE_DWC_OTG ?= "dwc_otg.lpm_enable=0"
+CMDLINE_ROOTFS ?= "root=/dev/mmcblk0p2 rootfstype=ext4 rootwait"
+
+CMDLINE_SERIAL ?= "${@oe.utils.conditional("ENABLE_UART", "1", "console=serial0,115200", "", d)}"
+
+CMDLINE_CMA ?= "${@oe.utils.conditional("RASPBERRYPI_CAMERA_V2", "1", "cma=64M", "", d)}"
+
+CMDLINE_PITFT ?= "${@bb.utils.contains("MACHINE_FEATURES", "pitft", "fbcon=map:10 fbcon=font:VGA8x8", "", d)}"
+
+# Add the kernel debugger over console kernel command line option if enabled
+CMDLINE_KGDB ?= '${@oe.utils.conditional("ENABLE_KGDB", "1", "kgdboc=serial0,115200", "", d)}'
+
+# Disable rpi logo on boot
+CMDLINE_LOGO ?= '${@oe.utils.conditional("DISABLE_RPI_BOOT_LOGO", "1", "logo.nologo", "", d)}'
+
+# You can define CMDLINE_DEBUG as "debug" in your local.conf or distro.conf
+# to enable kernel debugging.
+CMDLINE_DEBUG ?= ""
+
+CMDLINE = " \
+    ${CMDLINE_DWC_OTG} \
+    ${CMDLINE_SERIAL} \
+    ${CMDLINE_ROOTFS} \
+    ${CMDLINE_CMA} \
+    ${CMDLINE_KGDB} \
+    ${CMDLINE_LOGO} \
+    ${CMDLINE_PITFT} \
+    ${CMDLINE_DEBUG} \
+    "
+
+do_compile() {
+    echo "${CMDLINE}" > "${WORKDIR}/cmdline.txt"
+}
+
+do_deploy() {
+    install -d "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
+    install -m 0644 "${WORKDIR}/cmdline.txt" "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
+}
+
+addtask deploy before do_build after do_install
+do_deploy[dirs] += "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"