meta-raspberrypi: subtree update:09a3c11696..3a1fec22c0

Jan-Simon Moeller (1):
      python3-sense-hat: Switch to using pillow instead of imaging module

Jose Quaresma (3):
      gstreamer1.0-plugins-good: add package config knob to enable rpicamsrc plugin
      gstreamer1.0-plugins-good: enable rpicamsrc plugin
      gstreamer1.0-plugins-base: drop custom cppflags

Khem Raj (9):
      linux-raspberrypi: Do not use += with append
      python3-sense-hat: Move to dynamic-layers
      layer.conf: Add hardknott (3.3) to acceptable releases
      linux-raspberrypi_5.4.bb: Update to 5.4.79
      raspberrypi-firmware: Update to latest to take 5.4.79 prebuilts
      userland: Upgrade to latest as of 20201027
      raspberrypi-tools: Update to latest on master
      armstubs: Always use gcc compiler
      packagegroup-rpi-test: Add python3-sense-hat in a meta-python specific bbappend

Madhavan Krishnan (1):
      libcamera: Enabled camera overlays define based

Martin Jansa (3):
      gstreamer1.0-omx: rename bbappend to match new 1.18.0 version from oe-core
      layer.conf: Remove older releases from LAYERSERIES_COMPAT
      Revert "gstreamer1.0-plugins-good: add package config knob to enable rpicamsrc plugin"

Ming Liu (1):
      rpi-u-boot-scr: drop hard-coded 'arm'

Paul Barker (9):
      linux-raspberrypi: Convert dynamic config patching to config fragments
      sdcard_image-rpi: Drop redundant dependency on rpi-config:do_deploy
      rpi-cmdline: Move cmdline.txt generation to a separate recipe
      bootfiles: Use BOOTFILES_DIR_NAME variable
      rpi-bootfiles: Rename recipe to avoid ambiguity
      linux-raspberrypi: Remove obsolete kernel versions
      linux-raspberrypi: Drop unused rpi-kernel-misc config fragment
      linux-raspberrypi: Merge v5.4 recipe & inc file
      linux-raspberrypi-dev: Update for testing v5.10.y

Trevor Woerner (1):
      userland: add knob for ALL_APPS

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I90e0cba993e7f5bae2e56f2d40fd2f69211c2648
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
index 9489951..e1c330d 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -178,6 +178,12 @@
         echo "dtoverlay=${VC4DTBO}" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt
     fi
 
+    # Choose Camera Sensor to be used, default imx219 sensor
+    if [ "${RASPBERRYPI_CAMERA_V2}" = "1" ]; then
+        echo "# Enable Sony RaspberryPi Camera" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt
+        echo "dtoverlay=imx219" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt
+    fi
+
     # Waveshare "C" 1024x600 7" Rev2.1 IPS capacitive touch (http://www.waveshare.com/7inch-HDMI-LCD-C.htm)
     if [ "${WAVESHARE_1024X600_C_2_1}" = "1" ]; then
         echo "# Waveshare \"C\" 1024x600 7\" Rev2.1 IPS capacitive touch screen" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt