meta-raspberrypi: subtree update:09a3c11696..3a1fec22c0

Jan-Simon Moeller (1):
      python3-sense-hat: Switch to using pillow instead of imaging module

Jose Quaresma (3):
      gstreamer1.0-plugins-good: add package config knob to enable rpicamsrc plugin
      gstreamer1.0-plugins-good: enable rpicamsrc plugin
      gstreamer1.0-plugins-base: drop custom cppflags

Khem Raj (9):
      linux-raspberrypi: Do not use += with append
      python3-sense-hat: Move to dynamic-layers
      layer.conf: Add hardknott (3.3) to acceptable releases
      linux-raspberrypi_5.4.bb: Update to 5.4.79
      raspberrypi-firmware: Update to latest to take 5.4.79 prebuilts
      userland: Upgrade to latest as of 20201027
      raspberrypi-tools: Update to latest on master
      armstubs: Always use gcc compiler
      packagegroup-rpi-test: Add python3-sense-hat in a meta-python specific bbappend

Madhavan Krishnan (1):
      libcamera: Enabled camera overlays define based

Martin Jansa (3):
      gstreamer1.0-omx: rename bbappend to match new 1.18.0 version from oe-core
      layer.conf: Remove older releases from LAYERSERIES_COMPAT
      Revert "gstreamer1.0-plugins-good: add package config knob to enable rpicamsrc plugin"

Ming Liu (1):
      rpi-u-boot-scr: drop hard-coded 'arm'

Paul Barker (9):
      linux-raspberrypi: Convert dynamic config patching to config fragments
      sdcard_image-rpi: Drop redundant dependency on rpi-config:do_deploy
      rpi-cmdline: Move cmdline.txt generation to a separate recipe
      bootfiles: Use BOOTFILES_DIR_NAME variable
      rpi-bootfiles: Rename recipe to avoid ambiguity
      linux-raspberrypi: Remove obsolete kernel versions
      linux-raspberrypi: Drop unused rpi-kernel-misc config fragment
      linux-raspberrypi: Merge v5.4 recipe & inc file
      linux-raspberrypi-dev: Update for testing v5.10.y

Trevor Woerner (1):
      userland: add knob for ALL_APPS

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I90e0cba993e7f5bae2e56f2d40fd2f69211c2648
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
index bb4a64ef..9b2b6f3 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
@@ -5,19 +5,27 @@
         raise bb.parse.SkipRecipe(msg)
 }
 
-FILESEXTRAPATHS_prepend := "${THISDIR}/linux-raspberrypi:"
+LINUX_VERSION ?= "5.10.y"
+LINUX_RPI_BRANCH ?= "rpi-5.10.y"
 
-LINUX_VERSION ?= "4.19"
-LINUX_RPI_BRANCH ?= "rpi-4.19.y"
+SRCREV_machine = "${AUTOREV}"
+SRCREV_meta = "${AUTOREV}"
 
-SRCREV = "${AUTOREV}"
+KMETA = "kernel-meta"
+
 SRC_URI = " \
-    git://github.com/raspberrypi/linux.git;protocol=git;branch=${LINUX_RPI_BRANCH} \
+    git://github.com/raspberrypi/linux.git;name=machine;protocol=git;branch=${LINUX_RPI_BRANCH} \
+    git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=master;destsuffix=${KMETA} \
+    file://powersave.cfg \
+    file://android-drivers.cfg \
     "
+
 require linux-raspberrypi.inc
 
+LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
+
+KERNEL_EXTRA_ARGS += "DTC_FLAGS='-@ -H epapr'"
+
 # Disable version check so that we don't have to edit this recipe every time
 # upstream bumps the version
 KERNEL_VERSION_SANITY_SKIP = "1"
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"