wspoon: Run max31785 firmware revision checker

Run the MAX31785 firmware revision checking MSL (minimum ship level)
script on Witherspoon systems.  MSL can be used to prevent downlevel
fan cards escapes from manufacturing environments.

The script is configured to run on the way to BMC standby and
sets the MSL interfacee property on the configured fan inventory items.
Validation of the fan MSL interface is beyond the scope of this commit.

On Witherspoon, MSL enforcement is enabled by default.  For information
on disabling the MSL consult:

https://github.com/openbmc/phosphor-dbus-interfaces/blob/master/xyz/openbmc_project/Control/MinimumShipLevel.interface.yaml

Change-Id: Iaf5dbf8fc29bd497c9b2e610ba23ee98ee749d24
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
index ebdcac8..0f16ec5 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
@@ -24,3 +24,6 @@
 ENVS = "obmc/hwmon/{0}"
 SYSTEMD_ENVIRONMENT_FILE_${PN} += "${@compose_list(d, 'ENVS', 'WSPOON_ITEMS')}"
 SYSTEMD_ENVIRONMENT_FILE_${PN} += "${@compose_list(d, 'ENVS', 'WSPOON_OCCITEMS')}"
+
+SYSTEMD_ENVIRONMENT_FILE_max31785-msl += "obmc/hwmon-max31785/wspoon.conf"
+SYSTEMD_LINK_max31785-msl += "../phosphor-max31785-msl@.service:${SYSTEMD_DEFAULT_TARGET}.wants/phosphor-max31785-msl@wspoon.service"