sdbusplus: use python3

(From meta-phosphor rev: 11d5972170def0cafb42297f179312504a36ad02)

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I0cb4eac12be86aa9379992756a5757ea2c51591a
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
index 1709906..2fa4379 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
@@ -2,7 +2,7 @@
 DESCRIPTION = "C++ bindings for systemd dbus APIs."
 
 inherit autotools pkgconfig
-inherit obmc-phosphor-python-autotools
+inherit obmc-phosphor-python3-autotools
 
 include sdbusplus-rev.inc
 
@@ -13,6 +13,8 @@
         ${PYTHON_PN}-pyyaml-native \
         "
 
+SRC_URI += "file://0001-sdbus-switch-to-python3.patch"
+
 PACKAGECONFIG ??= "libsdbusplus transaction"
 PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
 PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction"