Add bmcweb target to S2600Wf

This changeset replaces phosphor rest with bmcweb for the s2600wf
target.  bmcweb has several advantages over phosphor-rest.
1. Written in C++.
2. Supports Asyncronous transactions
3. Authentication backed by PAM
4. SSL key generation, and modern SSL cipher suites
See the application readme for more

To enable bmcweb, this patchset also:
1. Revs libtinyxml to the latest version 6.0.0 from the existing 3.0.0
2. Adds the boost-dbus recipe, to allow bmcweb to build.  Bmcweb is a
header only dbus library.

Change-Id: I5b90427977709127c09fedcfc4bcb713908d356f
Signed-off-by: Ed Tanous <ed.tanous@intel.com>
diff --git a/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb.bb b/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb.bb
new file mode 100644
index 0000000..8d12c4b
--- /dev/null
+++ b/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb.bb
@@ -0,0 +1,34 @@
+inherit obmc-phosphor-systemd
+inherit useradd
+
+USERADD_PACKAGES = "${PN}"
+
+# add a user called httpd for the server to assume
+USERADD_PARAM_${PN} = "-r -s /usr/sbin/nologin bmcweb"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
+
+SRC_URI = "gitsm://github.com/openbmc/bmcweb.git"
+
+PV = "1.0+git${SRCPV}"
+SRCREV = "8db6e57bbad48443eb75ba3b13a5dad0abe06aec"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "dbus openssl zlib boost libpam boost-dbus gtest nlohmann-json libtinyxml2 "
+
+FILES_${PN} += "${datadir}/** "
+
+inherit cmake
+
+EXTRA_OECMAKE = "-DBUILD_UT=OFF -DYOCTO_DEPENDENCIES=ON"
+
+SYSTEMD_SERVICE_${PN} += "bmcweb.service"
+
+FULL_OPTIMIZATION = "-Os -pipe "
+
+do_install_append() {
+    rm -rf ${D}${includedir}/dbus
+    rm -rf ${D}${libdir}/cmake
+}