Add bmcweb target to S2600Wf

This changeset replaces phosphor rest with bmcweb for the s2600wf
target.  bmcweb has several advantages over phosphor-rest.
1. Written in C++.
2. Supports Asyncronous transactions
3. Authentication backed by PAM
4. SSL key generation, and modern SSL cipher suites
See the application readme for more

To enable bmcweb, this patchset also:
1. Revs libtinyxml to the latest version 6.0.0 from the existing 3.0.0
2. Adds the boost-dbus recipe, to allow bmcweb to build.  Bmcweb is a
header only dbus library.

Change-Id: I5b90427977709127c09fedcfc4bcb713908d356f
Signed-off-by: Ed Tanous <ed.tanous@intel.com>
diff --git a/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb b/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
index 7733e13..507f149 100644
--- a/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
+++ b/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
@@ -46,4 +46,6 @@
 SUMMARY_${PN}-system = "Intel System"
 RDEPENDS_${PN}-system = " \
         obmc-mgr-system \
+        bmcweb \
+        phosphor-webui \
         "