meta-amd: fix compilation errors with latest Yocto

Make the following changes to fix compilation errors:
- add honister to the LAYERSERIES_COMPAT variable,
- increase CONF_VERSION to 2,
- use new bitbake override syntax

Signed-off-by: Konstantin Aladyshev <aladyshev22@gmail.com>
Change-Id: I971f0f0f7110e0350994ced151ca429444885056
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend
index 5a28769..f55bf23 100644
--- a/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-SRC_URI_append = " file://ethanolx-baseboard.json \
+FILESEXTRAPATHS:append := ":${THISDIR}/${PN}"
+SRC_URI:append = " file://ethanolx-baseboard.json \
                    file://ethanolx-chassis.json"
 
-do_install_append() {
+do_install:append() {
      rm -f ${D}/usr/share/entity-manager/configurations/*.json
      install -d ${D}/usr/share/entity-manager/configurations
      install -m 0444 ${WORKDIR}/ethanolx-baseboard.json ${D}/usr/share/entity-manager/configurations