meta-amd: fix compilation errors with latest Yocto

Make the following changes to fix compilation errors:
- add honister to the LAYERSERIES_COMPAT variable,
- increase CONF_VERSION to 2,
- use new bitbake override syntax

Signed-off-by: Konstantin Aladyshev <aladyshev22@gmail.com>
Change-Id: I971f0f0f7110e0350994ced151ca429444885056
diff --git a/meta-amd/recipes-amd/amd-fpga/amd-fpga.bb b/meta-amd/recipes-amd/amd-fpga/amd-fpga.bb
index 32efdde..79c80b0 100644
--- a/meta-amd/recipes-amd/amd-fpga/amd-fpga.bb
+++ b/meta-amd/recipes-amd/amd-fpga/amd-fpga.bb
@@ -1,11 +1,11 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/${MACHINE}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}/${MACHINE}:"
 SUMMARY = "AMD Ethanolx FPGA Register Dump Utility"
 DESCRIPTION = "AMD Ethanolx FPGA Register Dump Utility"
 
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=5e24678b8d0883d9dfa9e9473069ddd2"
 
-RDEPENDS_${PN} = "bash"
+RDEPENDS:${PN} = "bash"
 SRCREV = "${AUTOREV}"
 SRC_URI =  "file://fpgardu.sh"
 SRC_URI += "file://LICENSE"