openpower-software-manager: Recipe fixes

When the do_install block was added to add the script files,
the binary from the git repository was no longer installed
in the package. Replace with do_install_append.
Also remove the duplicated source variable S.
And reorder the recipe to make it cleaner.

Closes openbmc/openbmc#1713

Change-Id: Iae814884a1b90dd15ea9ead010d4e26f22aa7ca1
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/openpower-software-manager.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/openpower-software-manager.bb
index 4c0f2e2..2071033 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/openpower-software-manager.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/openpower-software-manager.bb
@@ -24,18 +24,24 @@
         sdbusplus \
         "
 
-S = "${WORKDIR}"
+S = "${WORKDIR}/git"
+
+SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
+
 SRC_URI += " \
         file://bios-ubiattach \
         file://bios-ubiformat"
 
-do_install() {
+SRCREV = "5ba6b10e0b3622ceb920a07d1094af7607ae5dff"
+
+do_install_append() {
         install -d ${D}${sbindir}
         install -m 0755 ${WORKDIR}/bios-ubiattach ${D}${sbindir}/bios-ubiattach
         install -m 0755 ${WORKDIR}/bios-ubiformat ${D}${sbindir}/bios-ubiformat
 }
 
 DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service"
+
 SYSTEMD_SERVICE_${PN} += " \
         obmc-flash-bios-ubiattach.service \
         obmc-flash-bios-ubimount@.service \
@@ -43,8 +49,3 @@
         obmc-flash-bios-ubiumount-rw@.service \
         obmc-flash-bios-squashfsmount@.service \
         "
-
-SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
-SRCREV = "5ba6b10e0b3622ceb920a07d1094af7607ae5dff"
-
-S = "${WORKDIR}/git"