meta-ibm: witherspoon: fix file search paths

Typically it does not make any sense to append to FILESEXTRAPATHS.
FILESEXTRAPATHS is set in a bbappend when overriding something from
another layer.  The typical desire will be to make bitbake search for
files in the layer with the bbappend and not some other layer earlier in
the priority list.  Further, appending to FILESEXTRAPATHS will introduce
unexpected behavior when multiple layers append the same recipe - layers
with higher layer priorities that append to FILESEXTRAPATHS will find
their files overriden by files in layers with lower priorities.

(From meta-ibm rev: a588016cb556b425a00286ace2c8324590aac98b)

Change-Id: I7672219fdab5e2c9cc03423d7f507ef2e6a842c2
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-ibm/meta-witherspoon/recipes-core/systemd/systemd_%.bbappend b/meta-ibm/meta-witherspoon/recipes-core/systemd/systemd_%.bbappend
index 847714b..62ea76f 100644
--- a/meta-ibm/meta-witherspoon/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-core/systemd/systemd_%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 SRC_URI += "file://journald-storage-policy.conf"
 SRC_URI += "file://systemd-journald-override.conf"
 SRC_URI += "file://journald-size-policy.conf"