u-boot-aspeed: workaround old in-tree libfdt

U-boot has its own FDT implementation but it isn't isolated in terms
of include search paths very well in our ~2016 snapshot.

Prior to now (December 2018) it wasn't noticeable but with the move to
yocto 2.6 and libfdt 1.4.5 the FDT implementations are different enough
that if you have libfdt headers installed on your build host (which
under Yocto, is _always_) you will have host contanmination and 2016
u-boot will fail to build.

Work was done in upstream u-boot during 2018 to address this, but
backporting would be a not-insignificant level of effort.  Instead, use
the following hack until such a time that we can rebase on a more
recent (circa end of 2018) u-boot tree.

(From meta-aspeed rev: 7f8140089d95a529bf50c6c71112385607a64bcf)

Change-Id: I7513e2c651040fab55c2e500a6e801d4f5120d9d
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb
index b3a41a2..ac1ead7 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb
@@ -3,3 +3,7 @@
 
 PROVIDES += "u-boot"
 DEPENDS += "dtc-native"
+
+# FIXME this can/should be removed when we have rebased off our
+# 2016 snapshot onto a more modern (circa late 2018) u-boot tree.
+BUILD_CFLAGS_remove = "-isystem${STAGING_INCDIR_NATIVE}"