meta-phosphor: npcm8xx.bbclass: change binary depends for do_pad_binary

Before do_pad_binary be exectued, those binaries need to be ready for
padding. Otherwise there are errors about "No such file or directory"
for those binaries.

Tested: build pass and boot up successfully

Signed-off-by: Tim Lee <timlee660101@gmail.com>
Change-Id: I602ad0fdd95f207978b7dd2ed492ff7ef40573fb
diff --git a/meta-phosphor/classes/image_types_phosphor_nuvoton_npcm8xx.bbclass b/meta-phosphor/classes/image_types_phosphor_nuvoton_npcm8xx.bbclass
index 100102e..913286e 100644
--- a/meta-phosphor/classes/image_types_phosphor_nuvoton_npcm8xx.bbclass
+++ b/meta-phosphor/classes/image_types_phosphor_nuvoton_npcm8xx.bbclass
@@ -114,7 +114,7 @@
         int(d.getVar('UBOOT_ALIGN', True)), int(d.getVar('ALIGN_END', True)))
 }
 
-do_prepare_bootloaders[depends] += " \
+do_pad_binary[depends] += " \
     npcm8xx-tip-fw:do_deploy \
     npcm8xx-bootblock:do_deploy \
     u-boot-nuvoton:do_deploy \