blob: 85dede1779a18275662af58f4f33abf1672d75ba [file] [log] [blame]
SUMMARY = "display dialog boxes from shell scripts"
DESCRIPTION = "Dialog lets you to present a variety of questions \
or display messages using dialog boxes from a shell \
script (or any scripting language)."
HOMEPAGE = "http://invisible-island.net/dialog/"
SECTION = "console/utils"
DEPENDS = "ncurses"
LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
SRC_URI = "ftp://ftp.invisible-island.net/${BPN}/${BP}.tgz \
"
SRC_URI[md5sum] = "a39ec183517bc1feaff017d067300b8c"
SRC_URI[sha256sum] = "453095abaec288bfbc1ca9faced917e17742cff1ea45ec46210071ac153562f9"
# hardcoded here for use in dialog-static recipe
S = "${WORKDIR}/dialog-${PV}"
inherit autotools-brokensep pkgconfig
EXTRA_OECONF = "--with-ncurses \
--disable-rpath-hack"
do_configure() {
gnu-configize --force
sed -i 's,${cf_ncuconfig_root}6-config,${cf_ncuconfig_root}-config,g' -i configure
sed -i 's,cf_have_ncuconfig=unknown,cf_have_ncuconfig=yes,g' -i configure
oe_runconf
}